Creating a Draft Standard with the IEEE-SA Word Template

IEEE Standards Publishing Procedure

Creating a Draft Standard in MS Word with the IEEE Standards Association (SA) Word Template

UPDATES TO IEEE STD DRAFT TEMPLATE (January 2008):

1) All list styles: updated line spacing to 3pt before + 3 pt after
2) Numbered lists: indentations updated
3) Frontmatter Introduction: first paragraph updated with surrounding box, parentheses removed
4) Increased length of title and other document information storage in required fields to accommodate for longer titles. Fields now have up to 65,400 character maximum length. Title wraps and scrollbars appear for long titles
5) Updated IEEEStds Paragraph style. Added 12pt after paragraphs (no extra return needed)
6) All headings have “Keep with next,” automatically resolves bad page breaks
7) Added centering to Table Data style and a left-justified Table Data (or Table Text) style
8) Updated Title style to 23-point text
9) Function to insert special characters into title field, Chair and Vice-chair name
10) Updated Table functions: added a Convert text to Table function
11) Updated Paste image function: paste as inline, not float over text, new image style to center
12) Added Separate Year of Copyright from Year-Of-Draft, added field in Req Info form to enter Year-Of-Copyright
13) Removed IEEE-SA logo from opening splash
14) Documentation: Added Master and sub-documents sections and updated instructions on collecting data from various template and non-template documents into one central document.
Creating a Draft Standard with the IEEE-SA Word Template

Table of Contents

Introduction ..................................................................................................................................................4
Setting Security ..............................................................................................................................................4
Using the Template Document to Create a Draft Standard .................................................................5
IEEEStd's Template Toolbar ........................................................................................................................6
  Required Info...........................................................................................................................................6
  Insert Standard Text -> ..........................................................................................................................7
    Headings -> ...........................................................................................................................................7
      Overview, Scope, and Purpose...........................................................................................................7
      References .........................................................................................................................................7
      Definitions .........................................................................................................................................7
      Acknowledgments ............................................................................................................................7
      Required Info (fields) -> .................................................................................................................8
  Insert Special -> ...................................................................................................................................8
    Bibliographic Entry ............................................................................................................................8
    Equation/eq. Numbering ......................................................................................................................9
    Start Numbered List ...........................................................................................................................9
    Footnote .............................................................................................................................................9
    Note or Notes .......................................................................................................................................9
    Caution/Warning ...............................................................................................................................9
    Add (Table of) Contents ....................................................................................................................9
    Amendments/Corrigenda -> Editing instructions .............................................................................10
  Tables -> ...............................................................................................................................................10
    Insert Table ......................................................................................................................................10
    Regular Table Caption .......................................................................................................................10
    Annex Table Caption .........................................................................................................................10
    Apply Table... style............................................................................................................................10
  Figures -> .............................................................................................................................................11
    Insert Figure/Graphic .........................................................................................................................11
    Regular Figure Caption ....................................................................................................................11
    Annex Figure Caption .......................................................................................................................11
  Definitions -> .......................................................................................................................................11
    Definitions (head) .............................................................................................................................11
    Format/number Terms+Definitions .................................................................................................11
    Set/change numbering level for all Terms ..........................................................................................12
    Sort Terms .........................................................................................................................................13
  Annexes -> ..........................................................................................................................................13
    Insert Annex Title ............................................................................................................................13
    Apply Annex Heading Style -> ........................................................................................................13
    Insert Bibliographic Entry ................................................................................................................13
  Document Operations -> ....................................................................................................................14
    Update All Fields ..............................................................................................................................14
    Show Field Shading ..........................................................................................................................14
    Hide Field Shading ...........................................................................................................................14
    Reset Document to New ..................................................................................................................14
  Help....................................................................................................................................................14
IEEEStd's Formatting Toolbar ...................................................................................................................15
  H1—H4 ..................................................................................................................................................15
Creating a Draft Standard with the IEEE-SA Word Template

Body Text ....................................................................................................................................................15

List (Dash) ..................................................................................................................................................15

Numbered List -> .......................................................................................................................................15
  Start New List...............................................................................................................................................16
  Apply List Level ...........................................................................................................................................16

Body Text Headings -> ................................................................................................................................16

Frontmatter -> ...............................................................................................................................................16
  Frontmatter Headings -> ............................................................................................................................16
  Level 1 (frontmatter only) ..........................................................................................................................17
  Abstract Header (first word only) ..............................................................................................................17
  Keywords Header (first word only) ...........................................................................................................17
  Other Frontmatter -> ................................................................................................................................17

Annex Headings -> ......................................................................................................................................17

Captions -> ....................................................................................................................................................18
  Regular Figure Caption ...............................................................................................................................18
  Regular Table Caption ...............................................................................................................................18
  Annex Table/Figure Caption ......................................................................................................................18

Special -> .....................................................................................................................................................18
  Bibliographic Entry ..................................................................................................................................18
  Caution/Warning .......................................................................................................................................18
  Computer code .........................................................................................................................................18
  Footnote ....................................................................................................................................................19
  Single Note or Multiple Notes ..................................................................................................................19
  Terms+Definitions ..................................................................................................................................19
  Equation ...................................................................................................................................................19
  Equation Variable List ..............................................................................................................................19
  (Page) Header ..........................................................................................................................................19
  (Page) Footer ..........................................................................................................................................19

Default Style ..............................................................................................................................................19

FAQs ..............................................................................................................................................................20

Important Note—Bibliographic Entries and Cross-Referencing ..............................................................21

Note—Drafting Amendments and Corrigenda ............................................................................................22

Note—Formatting Equation Variable Lists ..............................................................................................22

Note—Using Word To Create Repeating Table Headings ........................................................................22

Note—Using the Paste Function ................................................................................................................22

Note—Using Word’s Insert -> Cross-Reference Function ........................................................................23

Note—Formatting the Definitions Clause ..................................................................................................24

Note—Creating a PDF of the draft standard using Adobe .........................................................................24

Note—Using Master and Sub-documents ..................................................................................................27
  Importing an Existing Document into an IEEE Draft Standard ..................................................................27
  Creating sub-documents for an IEEE draft standard master document ..................................................28
Creating a Draft Standard with the IEEE-SA Word Template

Introduction

This document outlines each function supplied by the IEEE Standards template document. The template document is designed to make adhering to the style and layout requirements of draft IEEE Standards documents as easy as possible. The download should be used to build each IEEE-SA draft document.

Before creating the IEEE-SA draft, become familiar with the template functions listed here, as well as the latest version of the IEEE Standards Style Manual: http://standards.ieee.org/guides/style/

NOTE—The IEEE Standards template document uses Word macros to run various functions that will make formatting very simple for the user. What this means is security must be set so that the macros can run. Failure to do so may cause errors. See directions below for setting security options.

Setting Security

Before opening the document, one must Enable Macros. If Microsoft Word is set to High security, or if one Disables Macros, access to the template’s functionality will be lost.

Word 2000/ME/XP: Go to Tools -> Macro -> Security -> Security Level tab… Select Medium security, as in the figure below left, and click OK.

When opening the template document, click Enable Macros. See figure below right.

NOTE—If necessary remember to reset security settings when working with other documents.
Creating a Draft Standard with the IEEE-SA Word Template

Using the Template Document to Create a Draft Standard

The first step is change the name of the template document. This is to lessen confusion in the event of work with more than one standard, or more than one version of the same standard. Do one of the following:

Right-click on the file icon and choose “Rename” OR
With the file icon selected, click once on the filename text display OR
Open file and choose File->Save as…

Then, rename file to the current project name.

The next step is to enter basic information about the draft standard into the Required Info form. This form appears when the document is opened for the first time, and may be accessed at any time by clicking the leftmost button on the IEEEStds toolbar (“Required Info…”). Note that it is not necessary to enter all the information immediately, but it should be completed before submitting to IEEE.

The information entered in the Required Info form will appear in specified areas in the document, called fields. By using the Required Info form to update the necessary information, all areas of the document will contain consistent information, and each area will not need individual checking. The Required Info fields may be added to any area of the document using one of the special Insert functions, described later.

To write the draft, enter text by typing, or cutting and pasting from other documents; format text with the styles provided by the document; and use the automated functions to insert special text. (See Note below.)

NOTE—When using any of the Insert functions, position the cursor exactly where the inserted text should appear. If the cursor is in the wrong location, the inserted text will also appear in the wrong location.
Creating a Draft Standard with the IEEE-SA Word Template

IEEEStds Template Toolbar

This section details the functions provided by the IEEEStds Template toolbar.

**Required Info…**

This button presents a form that captures the information necessary for all draft standards documents. **THIS INFORMATION SHOULD BE UPDATED THROUGH THE REQUIRED INFO FORM.** Do not make edits to the text directly: doing so will result in loss of functionality for that field. Instead click the Required Info button and navigate to the data to be changed using the Tab key, arrows, or upper tabs. Make the changes and click OK to finalize the update.

If the title will not fully display, add text after the field in the document itself. After clicking OK to save updates, place cursor at the end of each title field in the document, and type or paste the rest of the title.

**NOTE**—If a mistake is made, or if the field is corrupt and must be deleted, all fields can be reinserted using the Insert Standard text -> Required Info functions, and reformatted using the IEEEStds style functions.
Creating a Draft Standard with the IEEE-SA Word Template

Insert Standard Text ->

Headings ->
Selecting one of these will insert formatted, approved Standards text at the cursor.

Overview, Scope, and Purpose…
Inserts either the Scope header, or the Overview, Scope, and Purpose headers. IEEE draft standard style requires a Scope section, but does not require an Overview or Purpose section. If there is only a Scope, the Scope should be a first level header.
If an Overview section is desired, the Overview should be a first level header. In addition, both a Scope and a Purpose must be included as second level headers after the Overview.

References
Inserts the References header text (typically Clause 2): “The following referenced documents are indispensable for the application of this document. For dated references, only the edition cited applies. For undated references, the latest edition of the referenced document (including any amendments or corrigenda) applies."

Definitions
Inserts the Definitions header at the cursor (typically Clause 3): see Definitions -> Definitions (head) for the full inserted text and screen shot.

Acknowledgments
Inserts the Acknowledgments header at the cursor; this clause is ALWAYS part of the front matter section, and is optional. Acknowledgments are never in the body of the draft standard.
Creating a Draft Standard with the IEEE-SA Word Template

Required Info (fields)->
Selecting an item from this menu inserts the field chosen, displaying text as entered in the “Required Info” form. The advantage of Inserting Required Info fields, instead of simply typing the text, is the ability to update the text displayed in each field with the Required Info form. Required Info fields may be inserted anywhere in the document. If one of the fields that is part of the standard layout is deleted accidentally, these functions may be used, along with the document Styles, to recreate the correct format.

NOTE—The options of “Title Case” and “lowercase” are provided for “Trial Use” and “Guide/Recommended Practice/Standard,” so that they may be used either in displaying the full proper title of the draft (Title Case), or in displaying a short, indirect reference (lowercase).

Insert Special ->
Each selection in this menu inserts the specified item at the cursor. Except for “Add (Table of) Contents,” the user should not have any text selected when using each function.

NOTE—For the “Add (Table of) Contents” function, the user should select the text line that follows directly after the “Contents” head at the end of the front matter. Failing to do so may put the Contents in the wrong part of the document.

Bibliographic Entry
Applies “IEEEStds Bibliographic Entry” style to selection or new line
Creating a Draft Standard with the IEEE-SA Word Template

**Equation/Eq. Numbering…**
Function has two main parts-
1) Inserts an equation:
   —as a graphic or a Microsoft Equation object, AND
   —as a regular body equation or annex equation

   **NOTE**—All new equations must be added with this function to ensure correct formatting.

2) Inserts equation numbering only—necessary when an equation is moved within the document:
   —from the regular body to an annex, or from an annex to the body OR
   —from one annex to another

   Sequential numbering is maintained when an equation is moved within the body, or within the same annex. In these cases, new numbering is not needed.

**Start Numbered List**
Applies the “IEEEStd Numbered List” style to a new line or selection, and begins a new list.

**Footnote**
Inserts a footnote using Word’s functions with IEEE Standards style.

**Note or Notes…**
Inserts formatted “NOTE—” text for a single note to a new line, or starts Note numbering (for multiple Notes).

**Caution/Warning**
Inserts a Caution or Warning using input from a text field.

**Add (Table of) Contents**
Generates a hyperlinked Table of Contents, formatting according to IEEE Standards style. The cursor should be positioned on the last page of the front matter, the text outlined below selected, prior to activating the function.

> CONTENTS

> <After draft body is complete, select this text and click Insert Special → Add (Table of) Contents>
Amendments/Corrigenda -> Editing instructions

Inserts the text below:

NOTE—The editing instructions contained in this <amendment/corrigendum> define how to merge the material contained therein into the existing base standard and its amendments to form the comprehensive standard.

The editing instructions are shown in bold italic. Four editing instructions are used: change, delete, insert, and replace. **Change** is used to make corrections in existing text or tables. The editing instruction specifies the location of the change and describes what is being changed by using strikethrough (to remove old material) and underscore (to add new material). **Delete** removes existing material. **Insert** adds new material without disturbing the existing material. Insertions may require renumbering. If so, renumbering instructions are given in the editing instruction. **Replace** is used to make changes in figures or equations by removing the existing figure or equation and replacing it with a new one. Editorial notes will not be carried over into future editions because the changes will be incorporated into the base standard.

NOTE—Be sure to replace “<amendment/corrigendum>” text above with either “amendment” or “corrigendum,” as applicable.

---

Tables ->

This menu contains functions to assist in the formatting of tables, for the regular body text and for annexes. Due to the complexity and variability of table formatting, the functions are basic, and allow the user to determine how best to present the information. To ensure correct formatting, consult the IEEE Standards style manual for specific formatting instructions.

**Insert Table…**

Provides the ability to insert a table using the regular Word function, with the option of adding a landscape-oriented page to accommodate very large or wide tables. An advantage of using this function (as opposed to rotating pages manually) is that it automatically resolves page-numbering issues that may arise due to the addition of section breaks.

**Regular Table Caption**

 Inserts a formatted caption at the cursor for a table in main body of document.

**Annex Table Caption**

 Inserts a formatted caption at the cursor for a table in an annex.

**Apply Table… style**

 Applies the table style indicated to the selection or new line.
Figures ->

Insert Figure/Graphic…
Same as regular Word function…moved to new menu.

Regular Figure Caption
Inserts formatted caption for figure in main body of document.

Annex Figure Caption
Inserts formatted caption for figure in an annex.

Definitions ->

This section contains functions for use with the Definitions clause.

Definitions (head)
Inserts the Definitions header at the cursor (typically Clause 3):
“For the purposes of this draft <opt=trial-use><gde./rec.
prac./std.>, the following terms and definitions apply. The
Authoritative Dictionary of IEEE Standards, should be referenced
for terms not defined in this clause.”

See Format Terms+Definitions below for more info on adding and
formatting terms and definitions.

Format/number Terms+Definitions
Formats terms and their definitions according to IEEE Standards style, automatically. Here’s what to do (see the
note on formatting the Definitions clause for further details):
1) TYPE OR COPY AND PASTE TERM AND DEFINITION TEXT, ENSURING THE FOLLOWING CONVENTION:
term: definition<return>
   (Term, followed by a colon, followed by the definition, followed by a return)
Creating a Draft Standard with the IEEE-SA Word Template

Example:
electricity: flow of electrons
irony: unexpected ending

2) SELECT ALL TERMS AND DEFINITIONS AT ONCE, THEN APPLY FUNCTION.

NOTE—Definitions formatting is quite complex, and should be applied with this function. Definitions do not use the standard Bullets and Numbering style: typing return at the end of a definition will NOT automatically add numbering to the new line. The Format/number Terms+Definitions function must be used for new terms and definitions added to the clause. Do not attempt to format manually.

Below is a visual sample of correctly formatted definitions. The Definitions clause that is a first-level heading, and is the third such heading in the document:

3.1 electricity: flow of electrons
3.2 irony: unexpected ending

If the Definitions clause is a second-level heading (4.2, for example), then:

4.2.1 electricity: flow of electrons
4.2.2 irony: unexpected ending

Set/change numbering level for all Terms
Sets or changes numbering level for terms. The first time the Definitions style is applied with Format Terms +Definitions, set the level to correspond to the current level of the Definitions clause. So,

If Definitions clause is 1st-level: 3. Definitions
Terms will be 2nd-level: 3.1 term1, etc.

If Definitions clause is 2nd-level: 3.4 Definitions
Terms will be 3rd-level: 3.4.1 term1, etc.

If the Definitions clause number changes:
Document Operations -> Update All Fields, to update corresponding numbers in terms

If the Definitions clause level changes:
Definitions -> Set/change numbering level for all Terms, to change numbering level (both existing and new)

NOTE—Sequential term numbering updates automatically when the term and its number are moved in the list order.

NOTE—If the number of the Definitions clause itself changes, click Document Operations->Update All Fields, to reset the correct number(s).
Creating a Draft Standard with the IEEE-SA Word Template

Sort Terms...
Sorts paragraphs (terms+definitions) alphabetically. Same as Word function.

Parameters: Sort By Paragraphs, Ascending, with No header row.

Annexes ->

Insert Annex Title...
Inserts formatted Annex title; user types title into form, selects “normative” or “informative”. NOTE— the Annex title (Heading 1) style starts a new page for each annex.

Apply Annex Heading Style ->
Applies the style in parentheses to the text selection or new line. These styles should be used in annexes only.

Insert Bibliographic Entry
Applies “IEEEStds Bibliographic Entry” style to the selection or new line.
Creating a Draft Standard with the IEEE-SA Word Template

NOTE—When applying a style manually, be sure that the entire paragraph is selected (one sentence on its own is a paragraph). Many styles cannot be applied to only part of a paragraph.

Document Operations ->

The first three items in this menu perform global actions on the fields in the document. Fields are areas that display text based on:

- The contents of custom document fields, such as the PAR title and working group name,
- A sequence or calculated value, such as page numbers, or
- Document cross-references, such as the Table of Contents.

Field codes are the commands and switches that define what is shown in the field. Editing field codes is strongly discouraged.

NOTE—Editing the displayed text of a field directly will cause errors.

Update All Fields
Refreshes all document fields to their most current values. This function is useful for updating cross-references after the reference target has moved, or to hide field codes.

Show Field Shading
Displays field shading on the screen. Field shading does not print, and is helpful to show the non-editable areas of the document. Fields should not be edited directly.

Hide Field Shading
Removes field shading.

Reset Document to New
Resets document so that the opening splash screen and Required Info forms are displayed when next opened. This action can be helpful in showing new users basic document usage. All document fields and text remain unchanged. Or, get a new template document from http://standards.ieee.org/resources/development/writing/writinginfo.html

Help
Displays links to IEEE Standards style requirements and template instructions.

Help with IEEE Standards Style and Template

For detailed information on style requirements, go to the IEEE Standards Style Manual online:
http://standards.ieee.org/guides/style/

For information on using this template, go to the template instructions online:
http://standards.ieee.org/resources/development/writing/templates.html
Creating a Draft Standard with the IEEE-SA Word Template

IEEEStds Formatting Toolbar

This section details the functions provided by the IEEEStds Formatting toolbar.

NOTE—When applying a style manually, be sure that the entire paragraph is selected (one sentence on its own is a paragraph). A style cannot be applied to only part of a paragraph. EXCEPTION: Definition Terms + Numbering style can be applied to individual words or characters.

H1—H4
Applies “IEEEStds Level <x> Header” style to selection or new line; Level 1 through Level 4 corresponds to H1 through H4.

Body Text
Applies “IEEEStds Paragraph” style to selection or new line. This is the default style for all regular text: “Normal” or “Body Text” styles should not be used.

List (Dash)
Applies “IEEEStds Unordered List” style to selection or new line. Should be used for any bulleted list. To quickly navigate between list levels, press <Tab> to go up a level, and press Shift + <Tab> to go down a level. To end a list, press <Return> after the last list element, and apply “IEEE Paragraph” style by clicking “Body Text”.

Numbered List ->
To quickly navigate between list levels, press <Tab> to go up a level, and press Shift + <Tab> to go down a level. To end a list, press <Return> after the last list element, and apply “IEEE Paragraph” style by clicking “Body Text”.

NOTE—List numbering will continue for other lists unless the “Start New List” function is used.
Creating a Draft Standard with the IEEE-SA Word Template

Start New List
Applies “IEEEStds Numbered List Level 1” style, and starts a new numbered list at the cursor.

Apply List Level …
Applies the “IEEEStds Numbered List <level>” style to the selection or new line. List numbering will continue in later lists unless the “Start New List” function is used.

Body Text Headings ->
Applies “IEEEStds <level> Header” style to selection or new line, where <level> is one of the list at right.

Frontmatter ->
The following styles are intended for use ONLY in the frontmatter area.

NOTE—In general, the user will not need to apply these styles, as the front matter area is set up for the user either to input information using the “Required Info…” function, outlined above, or to select existing text and type or copy and paste over it. These styles are provided in the event of accidental reformatting or deletion of the required front matter text.

Frontmatter Headings ->
Frontmatter  Annex Headings  Captions  Special  Default Sty
Creating a Draft Standard with the IEEE-SA Word Template

Level 1 (frontmatter only)
Applies the “IEEEStds Level 1 (frontmatter)” style to the selection or new line.

Abstract Header (first word only)
Applies the “IEEEStds Abstract Header” character style to the selection. This style is special because it is only intended for adding bold typeface to the Abstract header and colon (“Abstract:”). All paragraphs of the abstract should have the “IEEEStds Abstract Body” style applied.

Keywords Header (first word only)
Applies the “IEEEStds Keywords Header” character style to the selection. The paragraph containing keywords should be formatted with the “IEEEStds Keywords” style.

Other Frontmatter ->
Applies the style listed at right to the selection or new line. The following styles are intended for use ONLY in the front matter area. See NOTE above.

Annex Headings ->
Applies the style in parentheses at right to the selection or new line.

NOTE—For the Annex Title, Annexes -> Insert Annex Title should be used, instead of just applying the style.

NOTE—The Annex Title style will start a new page for each Annex automatically. It is not necessary to add a manual page break.
Captions ->

This section formats captions for regular body text and annexes.

Regular Figure Caption
Applies the “IEEEStds Regular Figure Caption” style to the selection or new line. However, Figures -> Insert Regular Figure Caption should be used whenever possible.

Regular Table Caption
Applies the “IEEEStds Regular Table Caption” style to the selection or new line. However, Figures -> Insert Regular Table Caption function should be used whenever possible.

Annex Table/Figure Caption
Applies the “IEEEStds Annex Caption” style to the selection or new line. However, the Insert Annex Table Caption and Insert Annex Figure Caption function should be used whenever possible.

NOTE—If the Annex Title is not yet defined, or the title designated is not formatted with the proper style, the numbering of annex tables and figures may be incorrect, or the following text may appear in the field:

Error! No text of specified style in document.
This problem can be solved with Annexes -> Insert Annex Title..., or by selecting the title text and clicking Annex Headings -> Annex Title (Heading 1)

Special ->

Applies style from the list at right to the selection, or calls formatting function (if style requirements are complex).

Bibliographic Entry
Applies the “IEEEStds Bibliographic Entry” style to the selection or new line.

Caution/Warning
Calls the “Insert Caution/Warning...” function. See Insert Special -> Caution/Warning...

Computer code
Applies the “IEEEStds Computer Code” style to the selection or new line.
Creating a Draft Standard with the IEEE-SA Word Template

**Footnote**
Inserts a footnote using Word’s functions with IEEE Standards style.

**NOTE**—Microsoft Word cannot accommodate the complex footnoting style required by IEEE Standards style. For this reason, an IEEE Standards project editor will do proper footnoting at the end of the process. The user may wish to provide special instructions to the project editor for this purpose.

**Single Note or Multiple Notes**
Calls the “Insert Note or Notes…” function. See Insert Special -> Note or Notes…

**Terms+Definitions**
Calls the Terms+Definitions formatting function.

**Equation**
Calls the “Insert Equation…” function. See Insert Special -> Equation…

**NOTE**—The “Insert Equation” function must be used, or the equation numbering will not work correctly.

**Equation Variable List**
Applies the “IEEEStds Equation Variable List” style to the selection or new line. The user must add symbols and apply italics as necessary. Apply the style to a new line, type or insert the symbol, hit the Tab key, type the description, and format the symbol with italics if necessary at the end of the process.

**(Page) Header**
Applies the “IEEEStds Header” style to the selection or new line. It should not be necessary to use this style except in the case of accidental reformatting of the page header.

**(Page) Footer**
Applies the “IEEEStds Footer” style to the selection or new line. It should not be necessary to use this style except in the case of accidental reformatting of the page footer.

**Default Style**
 Resets the formatting of the selection to the default settings of the style currently applied. This function helps to ensure that the IEEE Standards style is followed correctly, by removing any extraneous formatting. It may be applied to the entire sections that use a variety of styles. However, it will not indicate whether areas of the document use the style required by IEEE.

**NOTE**—With a few exceptions, it should not be necessary to apply bold, italic, etc. Most required text styling can be accomplished by using the styles in the template document.
FAQs

Q. What does “Applies … style to selection or new line” mean?
A. If text is selected, the style is applied to the selection. If no text is selected, and the cursor is positioned at the beginning of a new line, the style is applied to any text that is then typed.

Q. I tried to apply a style to a selection, but nothing happened. Why?
A. A style cannot be applied to only part of a paragraph. To apply a style, select the entire paragraph first.

Q. What is the “front matter” of a draft standard?
A. The front matter area starts from the first page of the document (where the copyright statement is), and ends with the Table of Contents. The front matter area has lowercase Roman page numbers (i, ii, iii…).

Q. What is the “body” of a draft standard?
A. The body area is everything after the front matter. The body area has Arabic page numbers (1, 2, 3…).

Q. One or both of the IEEEStds toolbars is missing. What should I do?
A. Go to View --> Toolbars and select “IEEEStdsFormatting” and “IEEEStdsTemplate” at the bottom of the list. These toolbars are available only in the IEEEStds template document.

Q. The document looks fine on my system, but when I emailed it to my colleague, the toolbar disappeared. What should I do?
A. See answer to previous question.

Q. I used one of the template functions by accident, but when I hit Ctrl+Z (Undo previous action), it didn’t work. What should I do?
A. Many of the template functions consist of several actions, so if Ctrl+Z is used, it will only undo the last action of the series. Either continue to select Ctrl+Z until the template function is completely “undone”, or just select and delete the mistake and start over.

Q. My cross-references are not updating correctly. What should I do?
A. Cross-references can be corrupted by the editing process. The quickest solution is to delete the reference, and recreate it. See also the notes on using Word’s cross-referencing function, and avoiding errors in cross-referencing bibliographic references.
Creating a Draft Standard with the IEEE-SA Word Template

Important Note—Bibliographic Entries and Cross-Referencing

To avoid cross-referencing errors to bibliographic entries: **NEVER position the cursor at the beginning of an entry that is already being cross-referenced, and then hit Enter to get a new line for a new entry.** The result is that the cross-reference for the original bibliographic entry will include the text for the new bibliographic entry also. It will appear that the cross-reference now refers to the new entry, instead of the old.

It is recommended that the cursor be placed at the end of the line that comes before where the new entry should go, and hit Enter. To add an entry to the beginning of the list, place the cursor at the end of the Bibliography section heading and hit Enter. Add the entry by applying the Bibliographic Entry style to the line, or by selecting Insert Special->Bibliographic entry.

![Wrong](IMG1.png)

**Wrong**

Reference to second bibliographic entry (Ref2) [B2]

[B1] Ref1
[B2] Ref2
[B3] Ref3

(reference doesn’t change because the return character for the line above is included - BAD)

Document Operations -> Update All Fields

Reference to third bibliographic entry (Ref2) [B2]

[B1] Ref1
[B2] Ref2
[B3] Ref3
[B4] Ref3

![Right](IMG2.png)

**Right**

Reference to second bibliographic entry (Ref2) [B2]

[B1] Ref1
[B2] Ref2
[B3] Ref3

(Cursor is before the reference - GOOD)

Document Operations -> Update All Fields

Reference to third bibliographic entry (Ref2) [B3]

[B1] Ref1
[B2] Ref2
[B3] Ref3
[B4] Ref3

(Cursor is at the same point as the reference - BAD)

Reference updates correctly - GOOD
Creating a Draft Standard with the IEEE-SA Word Template

Note—Drafting Amendments and Corrigenda

To indicate that the working document is one of these, add the text “Amendment to…” or “Corrigendum to…” plus any specific title in the PAR title field of the Required Info form.

Since these documents reference only certain parts of an existing IEEE standard, it will likely be necessary to change the sequence number of a heading, equation, list item, etc. But applying the appropriate IEEEStds style or using one of the template functions will always automatically start at one and run in sequence.

For section heads only: to start a heading from a number other than one, or continue out of sequence:

1. Select the line and format the text using the proper IEEE heading level
2. Select Format->Bullets and Numbering
3. Click the Customize… button
4. Change the Start At field, by typing or clicking the arrows

For all other numbering, apply the correct style or use the function to demonstrate the desired final appearance, then delete the numbering and/or number field and use flat text to imitate the style. It is important to do this so as to prevent any automatic resequencing when the document is opened by an IEEE Standards editor.

Note—Formatting Equation Variable Lists

A style for variable lists has been provided (IEEEStds Equation Variable List). After using Insert Special -> Equation…, type Return after the equation, enter the text “where” followed by another Return, then apply the IEEEStds Equation Variable List style.

Once this has been done, each variable in the equation should be typed in its own line, followed by a tab, then the description of the variable. Then, select each variable in the list and apply italics to the variable character only. See the Standards style manual for further details on the style.

Note—Using Word To Create Repeating Table Headings

When tables cross pages, it is helpful to the reader to have the table headings repeated on subsequent pages. Here’s how to do it:

1. Select the row or rows to repeat (must include first row of table).
2. Turn on repeat table headings with (Word’s) Table -> Headings. Click Table -> Headings again to turn it off.

NOTE—Do not insert manual page breaks into the table. Repeated headings are visible in Page Layout view only. (For formatting, always use the Page Layout view, as the actual layout is most clearly seen.)

Note—Using the Paste Function

Formatted text from other documents may cause errors when pasted into the template. The special Paste Function controls the paste action based on the origin of the text to be pasted.

*Paste text from this document* (default): used with text/images from the same document. Simply hit Enter when the form at right appears.

*Paste text from another document:* formatted text from other documents must lose all formatting, then be reformatted using the styles in the template. (To paste entire documents or large sections, see Using Master and Sub-documents.)

*Paste image:* this function is incompatible with some picture formats. Word’s Insert -> Picture function may be used instead. (The picture must be in its own file, not an element in a larger document.)
Note—Using Word’s Insert -> Cross-Reference Function

The cross-reference function in Word can be very confusing to those who haven’t used it before (and often to those who have). This section will provide basic info regarding the interface and IEEE Standards style requirements.

The Reference Type is misleading as it applies to IEEE Standards style. Most items that can be cross-referenced appear in the list for Reference Type = Numbered Item, including table and figure captions in the body of the document, and all numbered equations. Annex table and figure captions appear under Reference Type = Table and Reference Type = Figure, respectively. Annex headings appear under Reference Type = Heading.

The table below tells which Insert Reference To value to select for each Reference Type, in order to get the correct text to appear as the cross-reference link.

<table>
<thead>
<tr>
<th>If Reference Type is:</th>
<th>Then Insert Reference To should be:</th>
<th>Applies to IEEE Standards element(s):</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numbered Item</td>
<td>Paragraph number (no context OR full context)</td>
<td>Regular table caption; regular figure caption; ordered or unordered list item; regular body heading (all levels); term+definition</td>
</tr>
<tr>
<td>Heading</td>
<td>Heading number (no context OR full context)</td>
<td>Annex headings (all levels)</td>
</tr>
<tr>
<td>Bookmark</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Footnote</td>
<td>Footnote number</td>
<td>Footnote</td>
</tr>
<tr>
<td>Endnote</td>
<td>Endnote number</td>
<td>Endnote</td>
</tr>
<tr>
<td>Equation</td>
<td>Only label and number</td>
<td>Equation</td>
</tr>
<tr>
<td>Figure</td>
<td>Entire caption or Only label and number</td>
<td>Annex table caption</td>
</tr>
<tr>
<td>Table</td>
<td>Entire caption or Only label and number</td>
<td>Annex figure caption</td>
</tr>
</tbody>
</table>

Each list will reflect the contents of each individual document.
Note—Formatting the Definitions Clause

The Definitions clause is somewhat different from other clauses in a draft standard, in that (if the clause is a first-level head) the second-level headings do not appear in the Table of Contents. (If the Definitions clause is itself a second-level head, it will appear in the TOC.) For this reason, a special numbering system is used for the terms.

Instead of numbering by using styles, terms are numbered using a special set of document fields. Use the following functions to insert term numbering, and format the term-definition:

Special -- Terms+Definitions
OR
Definitions -> Format Terms+Definitions

Numbering of terms consists of a reference to the main Definitions clause number, followed by a dot, followed by the number of the term in the list. So, if the Definitions clause is Clause 3, then

3.1 term1: definition 1
3.2 term2: definition 2

The number, term, and colon are bold, with the definition regular weight. All terms and definitions may be formatted and numbered at once with Special -- Terms+Definitions OR Definitions -> Format Terms+Definitions. Once added, if the number-term-definition is moved in the sequence, the term numbering (2nd field, after the dot) will update automatically.

If the Definitions clause number changes, such as when another clause is inserted before it:
Click Document Operations -> Update All Fields, or
Right-click on the first auto-number field (before the dot) and select Update Field.

The following process is recommended:
1. Type or copy and paste terms and definitions, making sure that each term-definition has a colon (:) after the term, and a return after the definition:
term1: definition1
term2: definition2
...
2. Click Special -- Terms+Definitions
   OR
   Definitions -> Format Terms+Definitions

At any time, the terms may be reordered, or new terms inserted. Always check that the numbering fields are correct.
To set or change the subhead level for terms automatically, if the Definitions clause changes from a 1st-level head to a 2nd-level head for example, click Definitions -- Change numbering level for all Terms…

Note—Creating a PDF of the draft standard using Adobe

The instructions below reference the Adobe 7.0 interface. Depending on the version of Adobe/Acrobat, the interface looks slightly different, and may include different options, but the basics are the same. You must have the full version of Adobe/Acrobat installed, along with the bundled PDFMaker (operates Distiller within Word).
Creating a Draft Standard with the IEEE-SA Word Template

Create a PDF with bookmarks, hyperlinks, linked cross-references, and fully embedded fonts:

Adobe PDF -> Change Conversion Settings

Settings:

Check the following boxes---
(optional) View Adobe PDF result
(optional) Prompt for Adobe PDF file name
(optional) Convert Document Information
(required) Add bookmarks to Adobe PDF
(required) Add links to Adobe PDF
(optional) Enable accessibility and reflow with Tagged PDF

THEN, click Advanced Settings…

Note on Conversion Settings: if the process for updating Advanced Settings for fonts (see below) has been done before, choose the updated Adobe PDF Settings profile that was created through that process.

Updating Advanced Settings (Adobe PDF/Distiller):

Click Fonts in left sidebar
Check “Embed all fonts”
Check “Subset embedded fonts…”
Enter “…when percent of characters is less than: 100%”
Make sure that the “Never Embed” list is empty (select any fonts in list and click Remove button)

Click Save As… and save font embedding settings to a new Adobe PDF Settings (Distiller) profile that can be used again (see Note on Conversion Settings above).
Creating a Draft Standard with the IEEE-SA Word Template

Word:

Check both of the following---
“Convert cross-references and table of contents to links”
“Convert footnotes and endnotes links”

Bookmarks:

Do NOT check “Convert Word Headings” OR “Convert Word Styles”, as this selection automatically checks several styles for bookmarking. However, note that when styles are checked individually, these checkboxes will become checked and grayed out.
Check ONLY the following styles:
Heading 1
Heading 2
IEEEStds Level 1 (front matter)
IEEEStds Level 1 Header
IEEEStds Level 2 Header

Finally, create the PDF with
Adobe PDF -> Convert to Adobe PDF
Creating a Draft Standard with the IEEE-SA Word Template

Note—Using Master and Sub-documents

If there are several small groups working on different sections of a draft standard, or if work on a standard began in a document that is not the IEEE Standards draft standard template, it may be an advantage to make use of master and sub-documents.

To create a master document:
1. Open a copy of the draft standard template
2. Select View -> Master Document
3. Save the document with this view.

The main functions in the Master Document toolbar to be used in conjunction with IEEE Standards draft standard template are highlighted above.

Sub-documents may be created from or added to the master document. One of the advantages of using a master document is to allow editing and importing of other documents by using the IEEE Standards template functions and styles, which are only available from within the template.

Note that even sub-documents created from the master document will not have the IEEEStds toolbars, functions, or the full set of styles. Only the master document, and other files that are copies of the IEEE Standards Word template, will have all necessary functions and styles.

Importing an Existing Document into an IEEE Draft Standard

If the draft standard development started in a Word file that is not the IEEE Standards draft standard template, here is an easy way to bring this document into the template. Basically, the original Word file is treated as a sub-document to the IEEE Standards draft standard template, and then is brought into the template by removing the sub-document reference:

1. Create/open the master (see above for details on creating a master document).
2. Place the cursor where the Word file to import belongs (always after the frontmatter section)
3. Click “Insert sub-document” in the Master Document toolbar
4. If prompted to rename styles in the sub-document click “No to All”

To continue to use the original Word file as a sub-document, perform all formatting tasks on the sub-document from within the master document. This includes using any of the IEEE Standards template functions (inserting equations, figures, tables, specialized text, etc.)

In most cases the best practice is to remove the sub-document reference, switch to Page Layout or Normal view, and continue work on the draft standard as a single, regular document (thereby discontinuing work within the original Word file):
Creating a Draft Standard with the IEEE-SA Word Template

5. Click the sub-document icon (appears at the top left of the sub-document text in the master), to select the sub-document.

6. Click “Remove sub-document” in the Master Document toolbar. The text from the sub-document will remain in the master, but the reference to the sub-document file is gone. Any further edits to the standard should be performed in the master.

7. Change to Normal or Page Layout view.

8. Format the (former) sub-document text using IEEE Standards styles and functions.

It is very important that all text brought in from a sub-document be formatted with IEEE Standards template formatting. No other styles or formatting should be used anywhere in an IEEE standard. Even if the text appears to mimic IEEE Standards style, it should be changed to use actual IEEE Standards base styles as given in the template.

Important: if Word styles Heading 1 through Heading 9 were used in the original file, they may appear as annex headings in the IEEE Standards draft standard template. Reformating using IEEE Standards body text headings will be required for these section heads.

Creating sub-documents for an IEEE draft standard master document

If starting out with all new documents (not existing ones as in the section above), in order to create subdocuments correctly, it is necessary to plan the subdocument sections:

Simple Case: If each group is not responsible for formatting, or if the structure of the subdocument is short and very simple (having only body text and headings) then the subdocument may be created from the master in the following way:

1. Create the master.
2. List the subdocument title as a section heading (body heading or annex heading).
3. Select the heading.
5. Save the master document.

This will create a subdocument named by the section it represents. This document should then be given to the responsible group for creation. The document will contain the main body text style and appropriate heading styles, but no other IEEE Standards styles or functions. If any of these more intricate styles or formats are needed, then the Simple Case does not apply to the situation. Use the instructions for the Complex Case instead.

Complex Case: If each group working on a subdocument is responsible for its own formatting, OR if the structure of each subdocument is complex (with tables, figures, other section types that require specialized formatting), the subdocument should also be created from a copy of the IEEE Standards draft template.

1. Create the master, save and close.
2. Open a new copy of the IEEE Standards draft standard template.
3. Enter all of the required document information as you would for the draft standard.
4. Click OK, and save the document with a name appropriate for a sub-document (filename references a particular section only).
5. Select all text, and delete. This action removes all the standard frontmatter, which is not necessary for the subdocument.
6. At the start of the document, enter and format the section heading that the sub-document represents.
7. Save and close the sub-document.
8. Open the master document.
9. Place the cursor where the subdocument you just created belongs, and click “Insert sub-document” in the Master Document toolbar. When prompted to rename styles in the sub-document click “No to All” The contents of the subdocument will now be visible. Click “Collapse sub-documents” in the Master Document toolbar to disable the view of the sub-document text, and show a link to the sub-document. Simply replace older versions of sub-documents with new versions to update the master.

Note that the section head numbering within the sub-document section will always start with 1 when the sub-document is viewed directly (not from within the master). When the sub-document is viewed within the master, the sub-document numbering will be in sequence with all other text within the master document, including other sub-documents referenced in the master.
IEEE P<designation>/D<draft_number>, <draft_month> <draft_year>

IEEE P<designation>™/D<draft_number>
Draft<opt_Trial-Use><Gde./Rec. Prac./Std.> for <Complete Title Matching PAR>

Prepared by the <Working Group Name> Working Group of the
<Committee Name> Committee

Copyright © <year> by the Institute of Electrical and Electronics Engineers, Inc.
Three Park Avenue
New York, New York 10016-5997, USA
All rights reserved.

This document is an unapproved draft of a proposed IEEE Standard. As such, this document is subject to change. USE AT YOUR OWN RISK! Because this is an unapproved draft, this document must not be utilized for any conformance/compliance purposes. Permission is hereby granted for IEEE Standards Committee participants to reproduce this document for purposes of international standardization consideration. Prior to adoption of this document, in whole or in part, by another standards development organization, permission must first be obtained from the IEEE Standards Activities Department (stds.ipr@ieee.org). Other entities seeking permission to reproduce this document, in whole or in part, must also obtain permission from the IEEE Standards Activities Department.

IEEE Standards Activities Department
445 Hoes Lane
Piscataway, NJ 08854, USA
Abstract: <Select this text and type or paste Abstract—contents of the Scope may be used>

Keywords: <Select this text and type or paste keywords>
This page is left blank intentionally.
Introduction

This introduction is not part of IEEE P<designation>/D<draft_number>, Draft<opt_Trial-Use><Gde./Rec. Prac./Std.> for <Complete Title Matching PAR>.

Notice to users

Laws and regulations

Users of these documents should consult all applicable laws and regulations. Compliance with the provisions of this standard does not imply compliance to any applicable regulatory requirements. Implementers of the standard are responsible for observing or referring to the applicable regulatory requirements. IEEE does not, by the publication of its standards, intend to urge action that is not in compliance with applicable laws, and these documents may not be construed as doing so.

Copyrights

This document is copyrighted by the IEEE. It is made available for a wide variety of both public and private uses. These include both use, by reference, in laws and regulations, and use in private self-regulation, standardization, and the promotion of engineering practices and methods. By making this document available for use and adoption by public authorities and private users, the IEEE does not waive any rights in copyright to this document.

Updating of IEEE documents

Users of IEEE standards should be aware that these documents may be superseded at any time by the issuance of new editions or may be amended from time to time through the issuance of amendments, corrigenda, or errata. An official IEEE document at any point in time consists of the current edition of the document together with any amendments, corrigenda, or errata then in effect. In order to determine whether a given document is the current edition and whether it has been amended through the issuance of amendments, corrigenda, or errata, visit the IEEE Standards Association web site at http://ieeexplore.ieee.org/xpl/standards.jsp, or contact the IEEE at the address listed previously.

For more information about the IEEE Standards Association or the IEEE standards development process, visit the IEEE-SA web site at http://standards.ieee.org.

Errata

Errata, if any, for this and all other standards can be accessed at the following URL: http://standards.ieee.org/reading/ieee/updates/errata/index.html. Users are encouraged to check this URL for errata periodically.
Interpretations

Current interpretations can be accessed at the following URL: http://standards.ieee.org/reading/ieee/interp/index.html.

Patents

Attention is called to the possibility that implementation of this opt_trial-use gde./rec. prac./std. may require use of subject matter covered by patent rights. By publication of this opt_trial-use gde./rec. prac./std., no position is taken with respect to the existence or validity of any patent rights in connection therewith. The IEEE is not responsible for identifying Essential Patent Claims for which a license may be required, for conducting inquiries into the legal validity or scope of Patents Claims or determining whether any licensing terms or conditions provided in connection with submission of a Letter of Assurance, if any, or in any licensing agreements are reasonable or non-discriminatory. Users of this opt_trial-use gde./rec. prac./std. are expressly advised that determination of the validity of any patent rights, and the risk of infringement of such rights, is entirely their own responsibility. Further information may be obtained from the IEEE Standards Association.

Participants

At the time this draft opt_trial-use gde./rec. prac./std. was completed, the <Working Group Name> Working Group had the following membership:

<Chair Name>, Chair

<Vice-chair Name>, Vice Chair

Participant1 Participant2 Participant3 Participant4 Participant5 Participant6 Participant7 Participant8 Participant9

The following members of the [individual/entity] balloting committee voted on this opt_trial-use gde./rec. prac./std. Balloters may have voted for approval, disapproval, or abstention.

(to be supplied by IEEE)
CONTENTS

After draft body is complete, select this text and click Insert Special->Add (Table of) Contents>

3
Draft<opt_Trial-Use><Gde./Rec. Prac./Std.> for <Complete Title Matching PAR>